summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-08 23:14:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 00:07:22 +0100
commit5167881a6087d3e7fb14380a6700263e954caf54 (patch)
treed5118154041fbf72254776e219d94579c200e819
parentde70f957b25ef6774a2cca5697bc8b55a3a20c95 (diff)
downloadguix-5167881a6087d3e7fb14380a6700263e954caf54.tar.gz
gnu: python-biopython: Update to 1.80.
* gnu/packages/bioinformatics.scm (python-biopython): Update to 1.80.
[build-system]: Use pyproject-build-system.
[arguments]: Remove trailing #T from build phase.
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 207f3c3d28..52abe152ee 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1237,21 +1237,21 @@ sequencing.")
 (define-public python-biopython
   (package
     (name "python-biopython")
-    (version "1.76")
+    (version "1.80")
     (source (origin
               (method url-fetch)
               ;; use PyPi rather than biopython.org to ease updating
               (uri (pypi-uri "biopython" version))
               (sha256
                (base32
-                "0wlch9xpa0fpgjzyxi6jsfca6iakaq9a05927xg8vqnmvaccnwrq"))))
-    (build-system python-build-system)
+                "0hqf3jsxn2sphcx81fx7x3i69sarpjsi70fzw98f8rw7z2d5x02j"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
+     '(#:phases
        (modify-phases %standard-phases
          (add-before 'check 'set-home
            ;; Some tests require a home directory to be set.
-           (lambda _ (setenv "HOME" "/tmp") #t)))))
+           (lambda _ (setenv "HOME" "/tmp"))))))
     (propagated-inputs
      (list python-numpy))
     (home-page "https://biopython.org/")