summary refs log tree commit diff
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2023-12-27 18:59:34 +0100
committerClément Lassieur <clement@lassieur.org>2024-01-12 18:57:46 +0100
commit51891106fa50c07509df9b4d0ef4632e8b685824 (patch)
treef2ff4cd7b1e71783f8068d98087b63e708789805
parent195c3e109679fa6638e3cd1a0f02529fca9da5b3 (diff)
downloadguix-51891106fa50c07509df9b4d0ef4632e8b685824.tar.gz
gnu: Add go-github-com-refraction-networking-utls.
* gnu/packages/golang.scm (go-github-com-refraction-networking-utls): New
variable.

Change-Id: Iefc22f54d37a0b1c5cbb54d72ee2dbea7494c5ef
-rw-r--r--gnu/packages/golang.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c775d0bfdc..d37232faeb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3697,6 +3697,42 @@ for the Go language.")
     (home-page "https://go.googlesource.com/crypto/")
     (license license:bsd-3)))
 
+(define-public go-github-com-refraction-networking-utls
+  (package
+    (name "go-github-com-refraction-networking-utls")
+    (version "1.6.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/refraction-networking/utls")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1iywar5vqsml4b177k2nkcxmjm8mw92g3p112yjsrpmikiwpwpyw"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/refraction-networking/utls"
+       #:go ,go-1.20
+       #:tests? #f))                    ;requires internet access
+    (propagated-inputs
+     (list go-github-com-andybalholm-brotli
+           go-github-com-cloudflare-circl
+           go-github-com-gaukas-godicttls
+           go-github-com-klauspost-compress
+           go-github-com-quic-go-quic-go
+           go-golang-org-x-crypto
+           go-golang-org-x-net
+           go-golang-org-x-sys))
+    (home-page "https://github.com/refraction-networking/utls")
+    (synopsis "Fork of the Go standard TLS library, providing low-level access
+to the ClientHello for mimicry purposes")
+    (description "uTLS is a fork of “crypto/tls”, which provides ClientHello
+fingerprinting resistance, low-level access to handshake, fake session tickets
+and some other features.  Handshake is still performed by “crypto/tls”, this
+library merely changes ClientHello part of it and provides low-level access.")
+    (license license:bsd-3)))
+
 (define-public govulncheck
   (package
     (name "govulncheck")