summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 00:26:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:40:05 +0200
commit51e14cd79787f890d01c0b911d6fd19dc1ec3a7a (patch)
treeef3a70588dffefbaef4a8b90757a6dd9b96d2fb0
parent7c54893c8ffb2816c040f36195c4dac255983298 (diff)
downloadguix-51e14cd79787f890d01c0b911d6fd19dc1ec3a7a.tar.gz
gnu: Add texlive-collection-langpolish.
* gnu/packages/tex.scm (texlive-collection-langpolish): New variable.
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fbe6247f95..cbb6a6deae 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34190,6 +34190,37 @@ simply on the size of the support.")
     (description "This collection provides support packages for Italian.")
     (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
 
+(define-public texlive-collection-langpolish
+  (package
+    (name "texlive-collection-langpolish")
+    (version (number->string %texlive-revision))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments (list #:builder #~(mkdir #$output)))
+    (propagated-inputs
+     (list texlive-babel-polish
+           texlive-bredzenie
+           texlive-cc-pl
+           texlive-collection-basic
+           texlive-collection-latex
+           texlive-gustlib
+           texlive-gustprog
+           texlive-hyphen-complete
+           texlive-lshort-polish
+           texlive-mex
+           texlive-mwcls
+           texlive-pl
+           texlive-polski
+           texlive-przechlewski-book
+           texlive-qpxqtx
+           texlive-tap
+           texlive-tex-virtual-academy-pl
+           texlive-utf8mex))
+    (home-page "https://www.tug.org/texlive/")
+    (synopsis "Support for Polish")
+    (description "This collection provides support packages for Polish.")
+    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
 (define-public texlive-collection-latex
   (package
     (name "texlive-collection-latex")