summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Dvorsak <eric@dvorsak.fr>2015-07-25 21:34:19 +0200
committerAlex Kost <alezost@gmail.com>2015-07-31 10:59:31 +0300
commit52323f32fa3d5c93249b7d76f9c7a1f1e906c86b (patch)
tree882e799cb898737e6180fc324e005b4ff59705ae
parent345f0611af635a9e525f6650e537b8a7ebfbfcd4 (diff)
downloadguix-52323f32fa3d5c93249b7d76f9c7a1f1e906c86b.tar.gz
gnu: Add python-ccm.
* gnu/packages/python.scm (python-ccm, python2-ccm): New variables.

Signed-off-by: Alex Kost <alezost@gmail.com>
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 88ab4427e1..a3802a42e0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -298,6 +298,35 @@ pidof, tty, taskset, pmap.")
 (define-public python2-psutil
   (package-with-python2 python-psutil))
 
+(define-public python-ccm
+  (package
+    (name "python-ccm")
+    (version "2.0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/c/ccm/ccm-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "199jw221albs2iv6xczczq88fxnh0aw8hzmys8qkbzkd99dssng9"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (inputs
+     `(("python-pyyaml" ,python-pyyaml)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/pcmanus/ccm")
+    (synopsis "Cassandra Cluster Manager")
+    (description "A script/library to create, launch and remove an Apache
+Cassandra cluster on localhost.")
+    (license asl2.0)))
+
+(define-public python2-ccm
+  (package-with-python2 python-ccm))
+
 (define-public python-pytz
   (package
     (name "python-pytz")