summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-08-18 13:09:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-08-22 16:52:22 +0200
commit52765a63ca43a66137272e9826553c072c1ef769 (patch)
tree64e7f1a917b241d17fd796b2d5aa89b47076b338
parent17073dafc59d62fb8cbb8b94d61d3ecc488ac59f (diff)
downloadguix-52765a63ca43a66137272e9826553c072c1ef769.tar.gz
gnu: Add r-rhtslib.
* gnu/packages/bioinformatics.scm (r-rhtslib): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 233b7a8879..ade6e37579 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6325,6 +6325,31 @@ two-dimensional genome scans.")
 libraries for systems that do not have these available via other means.")
     (license license:artistic2.0)))
 
+(define-public r-rhtslib
+  (package
+    (name "r-rhtslib")
+    (version "1.4.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "Rhtslib" version))
+       (sha256
+        (base32
+         "1wgpn9x8abjj7fc087pdavqc3fz0pl5xdh231mgjila18irwlhb3"))))
+    (properties `((upstream-name . "Rhtslib")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-zlibbioc" ,r-zlibbioc)))
+    (inputs
+     `(("zlib" ,zlib)))
+    (home-page "https://github.com/nhayden/Rhtslib")
+    (synopsis "High-throughput sequencing library as an R package")
+    (description
+     "This package provides the HTSlib C library for high-throughput
+nucleotide sequence analysis.  The package is primarily useful to developers
+of other R packages who wish to make use of HTSlib.")
+    (license license:lgpl2.0+)))
+
 (define-public emboss
   (package
     (name "emboss")