summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-25 19:08:41 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-26 00:19:38 +0200
commit52dd58b56dbcc7610a26275fe9782151d664bb68 (patch)
treedb08088ff155e63e6a055c88747a1f3e3d9246bd
parentdd070af55cd834e19348bc45aec3aa955ff42388 (diff)
downloadguix-52dd58b56dbcc7610a26275fe9782151d664bb68.tar.gz
gnu: nethogs: Don't use unstable tarball.
* gnu/packages/networking.scm (nethogs)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
[arguments]: Don't try (and fail) to determine the version using git.
-rw-r--r--gnu/packages/networking.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 0b6c6e7353..9f7548db9a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1724,21 +1724,23 @@ the bandwidth, loss, and other parameters.")
   (package
     (name "nethogs")
     (version "0.8.6")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/raboof/nethogs/archive/v"
-                                  version ".tar.gz"))
-              (sha256
-               (base32
-                "1875q9hx48g68pika7n51an879v3s10ir4sf95z6ggnl6m91sz1i"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/raboof/nethogs")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "0sn1sdp86akwlm4r1vmkxjjl50c0xaisk91bbz57z7kcsaphxna9"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (inputs
      `(("libpcap" ,libpcap)
        ("ncurses" ,ncurses)))
     (arguments
      `(#:make-flags `("CC=gcc"
-                      ,(string-append "PREFIX=" %output))
+                      ,(string-append "PREFIX=" %output)
+                      ,(string-append "VERSION=" ,version))
        #:phases
        (modify-phases %standard-phases
          (delete 'configure))))         ; no ./configure script.