summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:38:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:22 +0200
commit548424bab58dd9a98a1703582778ae6eaaf312d9 (patch)
tree3734c6c632177e567439bfa8386df7e80b85b9ff
parent58ce8aaa0d0f3ef40944ba9c38245f204d1beecd (diff)
downloadguix-548424bab58dd9a98a1703582778ae6eaaf312d9.tar.gz
gnu: Add texlive-librecaslon.
* gnu/packages/tex.scm (texlive-librecaslon): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 23a7d39328..3bcb6f8ad6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16591,6 +16591,32 @@ A BoldItalic variant has been artificially generated.")
 Fuenzalida, based on the 19th century Morris Fuller Benton's.")
     (license (list license:silofl1.1 license:lppl))))
 
+(define-public texlive-librecaslon
+  (package
+    (name "texlive-librecaslon")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/librecaslon/"
+                   "fonts/enc/dvips/librecaslon/"
+                   "fonts/map/dvips/librecaslon/"
+                   "fonts/opentype/impallari/librecaslon/"
+                   "fonts/tfm/impallari/librecaslon/"
+                   "fonts/type1/impallari/librecaslon/"
+                   "fonts/vf/impallari/librecaslon/"
+                   "tex/latex/librecaslon/")
+             (base32
+              "16lmaa0rsrgrib00r8rsj9librkybq2zf1as11l3hiw5zcq3wj0w")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/librecaslon")
+    (synopsis "Libre Caslon fonts, with LaTeX support")
+    (description
+     "The Libre Caslon fonts are designed by Pablo Impallari.  Although they
+have been designed for use as web fonts, they work well as conventional text
+fonts.  An artificially generated BoldItalic variant has been added.")
+    (license (list license:silofl1.1 license:lppl))))
+
 (define-public texlive-lie-hasse
   (package
     (name "texlive-lie-hasse")