summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-26 16:39:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-04 12:57:23 +0300
commit54df75582f224d896bb39eb37c9243971fa607bc (patch)
treefec163338e4867afa041f5f118667f0ec782a653
parentc607b7011c55932b46c2279b6fe013d730b78a50 (diff)
downloadguix-54df75582f224d896bb39eb37c9243971fa607bc.tar.gz
gnu: Add pinentry-qt.
* gnu/packages/gnupg.scm (pinentry-qt): New variable.
-rw-r--r--gnu/packages/gnupg.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 28ab67ce17..b7c661257c 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -31,6 +31,7 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pth)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages databases)
@@ -607,6 +608,17 @@ including tools for signing keys, keyring analysis, and party preparation.
      "Pinentry provides a console and a GTK+ GUI that allows users to enter a
 passphrase when @code{gpg} or @code{gpg2} is run and needs it.")))
 
+(define-public pinentry-qt
+  (package
+    (inherit pinentry-tty)
+    (name "pinentry-qt")
+    (inputs
+     `(("qt" ,qt)
+       ,@(package-inputs pinentry-tty)))
+  (description
+   "Pinentry provides a console and a Qt GUI that allows users to enter a
+passphrase when @code{gpg} or @code{gpg2} is run and needs it.")))
+
 (define-public pinentry
   (package (inherit pinentry-gtk2)
     (name "pinentry")))