summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 21:30:47 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 23:37:05 -0400
commit55f051e28ca94b529cfbe2c41157815fb4c810f6 (patch)
tree087c66ba5aa3d4170bb3736ea9ca0ca80f74a704
parent530cf34edbd5173e3973856600321e70815cc718 (diff)
downloadguix-55f051e28ca94b529cfbe2c41157815fb4c810f6.tar.gz
gnu: python-docutils: Update to 0.19.
* gnu/packages/python-xyz.scm (python-docutils): Update to 0.19.
[arguments]: Strip trailing #t.
(python-docutils-0.19): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 8 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ef740d8c91..373ddc69e3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5073,14 +5073,13 @@ leaf preserving the overall structure.")
 (define-public python-docutils
   (package
     (name "python-docutils")
-    (version "0.17.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "docutils" version))
-       (sha256
-        (base32
-         "09gii36lp1bs26cpxqyfd20xahnpbrbjzcnba2xq08y3wk97frb8"))))
+    (version "0.19")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "docutils" version))
+              (sha256
+               (base32
+                "1rprvir116g5rz2bgzkzgyn6mv0z8582rz7bgxbpy2y3adkmm69k"))))
     (build-system python-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
@@ -5088,8 +5087,7 @@ leaf preserving the overall structure.")
                     (lambda* (#:key tests? #:allow-other-keys)
                       (if tests?
                           (invoke "python" "test/alltests.py")
-                          (format #t "test suite not run~%"))
-                      #t)))))
+                          (format #t "test suite not run~%")))))))
     (home-page "https://docutils.sourceforge.net/")
     (synopsis "Python Documentation Utilities")
     (description
@@ -5103,18 +5101,6 @@ via commands such as @command{rst2man}, as well as supporting Python code.")
     ;; licensed under the PFSL, BSD 2-clause, and GPLv3+ licenses.
     (license (list license:public-domain license:psfl license:bsd-2 license:gpl3+))))
 
-;; TODO: Make this the default in the next rebuild cycle.
-(define-public python-docutils-0.19
-  (package
-    (inherit python-docutils)
-    (version "0.19")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "docutils" version))
-              (sha256
-               (base32
-                "1rprvir116g5rz2bgzkzgyn6mv0z8582rz7bgxbpy2y3adkmm69k"))))))
-
 ;; awscli refuses to be built with docutils < 0.16.
 (define-public python-docutils-0.15
   (package