summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-31 14:57:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:45:46 +0300
commit5678be9a3c6bc551f86649b3d97649f7bf7eb84c (patch)
tree40a624f950b712bf23e52f847063b241b426578c
parentdfa50b8624ae1750b9f038b648a68f98a83cacf8 (diff)
downloadguix-5678be9a3c6bc551f86649b3d97649f7bf7eb84c.tar.gz
gnu: Add rust-postcard-1.
* gnu/packages/crates-io.scm (rust-postcard-1): New variable.

Change-Id: I8378bf118f31dec6d0002e2989bbfa64b126e502
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7774a6e5c2..4753d4fd6f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -53926,6 +53926,34 @@ audio I/O library.")
 I/O library.")
     (license license:expat)))
 
+(define-public rust-postcard-1
+  (package
+    (name "rust-postcard")
+    (version "1.0.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "postcard" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1y106iwjv6vm7s4zkszgxlhacca1xbw6qcwf8il7xc0ddkp52p55"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-cobs" ,rust-cobs-0.2)
+                       ("rust-const-format" ,rust-const-format-0.2)
+                       ("rust-crc" ,rust-crc-3)
+                       ("rust-defmt" ,rust-defmt-0.3)
+                       ("rust-embedded-io" ,rust-embedded-io-0.4)
+                       ("rust-heapless" ,rust-heapless-0.7)
+                       ("rust-paste" ,rust-paste-1)
+                       ("rust-postcard-derive" ,rust-postcard-derive-0.1)
+                       ("rust-serde" ,rust-serde-1))))
+    (home-page "https://github.com/jamesmunns/postcard")
+    (synopsis "A no_std + serde compatible message library for Rust")
+    (description
+     "This package provides a no_std + serde compatible message library for Rust.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-postcard-derive-0.1
   (package
     (name "rust-postcard-derive")