summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 18:02:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 22:00:21 +0200
commit56d63f81199db597c62e1acd34758fad8e56d536 (patch)
tree4e965c8319551609193ba8dac363c8e6e7ca11e0
parentd6870d107e8aefb88a0d31c619b7bc715cb977c9 (diff)
downloadguix-56d63f81199db597c62e1acd34758fad8e56d536.tar.gz
gnu: git-crypt: Return #t from all phases.
* gnu/packages/version-control.scm (git-crypt)[arguments]: Substitute
INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/version-control.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 2a108ab0b8..5e21947aae 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -466,12 +466,12 @@ write native speed custom Git applications in any language with bindings.")
          (delete 'configure)
          (replace 'build
            (lambda _
-             (zero? (system* "make"))))
+             (invoke "make")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
-               (zero? (system* "make" "install"
-                               (string-append "PREFIX=" out)))))))))
+               (invoke "make" "install"
+                       (string-append "PREFIX=" out))))))))
     (home-page "https://www.agwa.name/projects/git-crypt")
     (synopsis "Transparent encryption of files in a git repository")
     (description "git-crypt enables transparent encryption and decryption of