summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-20 05:22:40 +0000
committerLars-Dominik Braun <lars@6xq.net>2021-05-08 11:27:49 +0200
commit570a4c77f892c4f625c0c638084a0549cb17bc58 (patch)
treed46d5abe640382705356b8bc0745bbe8e45c7512
parent83706ea9e91792f22eec900ff65372c49991297f (diff)
downloadguix-570a4c77f892c4f625c0c638084a0549cb17bc58.tar.gz
gnu: Add python-easyprocess.
* gnu/packages/python-xyz.scm (python-easyprocess): New variable.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8229649f86..dce50d6649 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15177,6 +15177,26 @@ etc.")
     (package/inherit base
       (name "ptpython2"))))
 
+(define-public python-easyprocess
+  (package
+    (name "python-easyprocess")
+    (version "0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "EasyProcess" version))
+       (sha256
+        (base32 "115rzzr0hx4af4m6krf7dxn8851n4l8jfxahjzjc2r0zq2m8v57v"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Tests require pyvirtualdisplay, which requires this package.
+     `(#:tests? #f))
+    (home-page "https://github.com/ponty/easyprocess")
+    (synopsis "Python subprocess interface")
+    (description
+     "@code{easyprocess} is an easy to use Python subprocess interface.")
+    (license license:bsd-3)))
+
 (define-public python-stem
   (package
     (name "python-stem")