summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 18:34:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:26 +0200
commit57f281132aafedf99bd61fc4f987fe8068aa9966 (patch)
tree08dd01428860894cc4a0e0a1b76bebaeab73ae1e
parent6e4aced69d594f0c99bc108569035ab687859202 (diff)
downloadguix-57f281132aafedf99bd61fc4f987fe8068aa9966.tar.gz
gnu: Add texlive-context-lettrine.
* gnu/packages/tex.scm (texlive-context-lettrine): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6d5ff8202f..7214779fce 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10382,6 +10382,26 @@ provided, with support covering ConTeXt Mkii and Mkiv.  The design of
 letters may be amended by a wide range of style specifications.")
     (license license:gpl3+)))
 
+(define-public texlive-context-lettrine
+  (package
+    (name "texlive-context-lettrine")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/context/third/lettrine/"
+                   "tex/context/interface/third/"
+                   "tex/context/third/lettrine/")
+             (base32
+              "0mhzvnn6ffysfq9qxdj1a6prplppzsh4pb7x2di2r87pnkxwa7f2")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-context))
+    (home-page "https://ctan.org/pkg/context-lettrine")
+    (synopsis "ConTeXt implementation of lettrines")
+    (description
+     "This is a re-implementation of the LaTeX package @code{lettrine}.")
+    (license license:public-domain)))
+
 (define-public texlive-beamer
   (package
     (name "texlive-beamer")