summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-27 18:27:12 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-27 19:03:25 +0200
commit58c3118f5916617fd6a8be88acb218df95a7fbc7 (patch)
tree278098eaf50964408c88f40e455a5f4c39ebbb91
parente58d05c32ecab9e08d3819538f0b0ea970232713 (diff)
downloadguix-58c3118f5916617fd6a8be88acb218df95a7fbc7.tar.gz
gnu: ocaml-re: Update to 1.9.0.
* gnu/packages/ocaml.scm (ocaml-re): Update to 1.9.0.
(ocaml-uri): Fix build.
-rw-r--r--gnu/packages/ocaml.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9766bb4b20..7ececfc25a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2531,7 +2531,7 @@ standard iterator type starting from 4.07.")
 (define-public ocaml-re
   (package
     (name "ocaml-re")
-    (version "1.8.0")
+    (version "1.9.0")
     (source
      (origin
        (method git-fetch)
@@ -2540,7 +2540,7 @@ standard iterator type starting from 4.07.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0ch6hvmm4ym3w2vghjxf3ka5j1023a37980fqi4zcb7sx756z20i"))))
+        (base32 "07ycb103mr4mrkxfd63cwlsn023xvcjp0ra0k7n2gwrg0mwxmfss"))))
     (build-system dune-build-system)
     (arguments
      `(#:tests? #f
@@ -2681,7 +2681,13 @@ JSON.")
         (base32 "1ppbav41mszpjcl0zi3fyg958cxyfs57i7kvha4ds9ydn89bjmrh"))))
     (build-system dune-build-system)
     (arguments
-     `(#:test-target "."))
+     `(#:test-target "."
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'update-deprecated
+           (lambda _
+             (substitute* "lib/uri.ml"
+               (("Re.get") "Re.Group.get")))))))
     (native-inputs
      `(("ocaml-ounit" ,ocaml-ounit)
        ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)))