summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-12 12:10:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-12 13:08:13 +0100
commit58e3603e7f5452026b9a5fa61bb771d153ead4f4 (patch)
tree737c6496d72cc45eb7a0bea2eb38f2999c35632b
parent138c08899ba73049de8afd2b74a8cf6845a1d9e1 (diff)
downloadguix-58e3603e7f5452026b9a5fa61bb771d153ead4f4.tar.gz
gnu: colordiff: Update to 1.0.18.
Also add the non-archive URL, which was probably the intention of commit
8d479d27ca74f86a69b48d385f3d9537adf5392b.  Better late than never.

* gnu/packages/patchutils.scm (colordiff): Update to 1.0.18.
-rw-r--r--gnu/packages/patchutils.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 1e4b3fbd1c..224b0e8d64 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -150,24 +151,26 @@ refreshed, and more.")
 (define-public colordiff
   (package
     (name "colordiff")
-    (version "1.0.16")
+    (version "1.0.18")
     (source
       (origin
         (method url-fetch)
-        (uri (list (string-append "http://www.colordiff.org/archive/colordiff-"
+        (uri (list (string-append "https://www.colordiff.org/colordiff-"
+                                  version ".tar.gz")
+                   (string-append "http://www.colordiff.org/archive/colordiff-"
                                   version ".tar.gz")))
       (sha256
        (base32
-        "12qkkw13261dra8pg7mzx4r8p9pb0ajb090bib9j1s6hgphwzwga"))))
+        "1q6n60n4b9fnzccxyxv04mxjsql4ddq17vl2c74ijvjdhpcfrkr9"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f
+     `(#:tests? #f                      ; no tests
        #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
                           "INSTALL_DIR=/bin" "MAN_DIR=/share/man/man1")
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)
-         (delete 'build))))
+         (delete 'configure)            ; no configure script
+         (delete 'build))))             ; nothing to build
     (inputs
      `(("perl" ,perl)
        ("xmlto" ,xmlto)))