summary refs log tree commit diff
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2024-01-11 11:20:43 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-01-12 12:41:18 +0100
commit5960c3cdc40a2cd905479d3abeef01dbaf26f3a7 (patch)
tree44993c5546910cb203840326b02b22c96f6a1c89
parent40f5a3ce437083e4f259878735c2c55f41708e81 (diff)
downloadguix-5960c3cdc40a2cd905479d3abeef01dbaf26f3a7.tar.gz
gnu: Add r-azimuth.
* gnu/packages/bioinformatics.scm (r-azimuth): New variable.

Change-Id: I2b0d087378028663ee8d76ced8950f7a9721cb03
Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioinformatics.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f574fea0e9..f75254ed9f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11171,6 +11171,65 @@ single-cell data.")
        "This package is designed to streamline scATAC analyses in R.")
       (license license:gpl2+))))
 
+(define-public r-azimuth
+  (let ((commit "243ee5db80fcbffa3452c944254a325a3da2ef9e")
+        (revision "1"))
+    (package
+      (name "r-azimuth")
+      (version (git-version "0.5.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/satijalab/azimuth")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0vs4813kf2cv2j1z800ihwk62bw4dgmwgkd47rln58581chv39zm"))))
+      (properties `((upstream-name . "Azimuth")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-bsgenome-hsapiens-ucsc-hg38
+                               r-dt
+                               r-ensdb-hsapiens-v86
+                               r-future
+                               r-ggplot2
+                               r-glmgampoi
+                               r-googlesheets4
+                               r-hdf5r
+                               r-htmltools
+                               r-httr
+                               r-jaspar2020
+                               r-jsonlite
+                               r-matrix
+                               r-patchwork
+                               r-plotly
+                               r-presto
+                               r-rcpp
+                               r-rlang
+                               r-scales
+                               r-seurat
+                               r-seuratdata
+                               r-seuratdisk
+                               r-seuratobject
+                               r-shiny
+                               r-shinybs
+                               r-shinydashboard
+                               r-shinyjs
+                               r-signac
+                               r-stringr
+                               r-tfbstools
+                               r-withr))
+      (home-page "https://github.com/satijalab/azimuth")
+      (synopsis
+       "Shiny app showcasing a single-cell data query-reference mapping algorithm")
+      (description "Azimuth utilizes an annotated reference dataset.  It
+automates the processing, analysis, and interpretation.  This applies
+specifically to new single-cell RNA-seq or ATAC-seq experiments.  Azimuth
+leverages a reference-based mapping pipeline that inputs acounts matrix and
+performs normalization, visualization, cell annotation, and differential
+expression.")
+      (license license:gpl3))))
+
 (define-public r-icellnet
   ;; v1.0 tagged in 2020, last commit contains many fixes.
   ;; DESCRIPTION says Version: 0.0.0.9000.