summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-16 22:24:19 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-17 09:53:18 +0200
commit5a3217e52cd5364684b8a295357187a53a26e437 (patch)
treecab6ae8d0bc67526a274bed5926b54d8b1af0a67
parent4711a24074da962c50fa446215060ed50eb52970 (diff)
downloadguix-5a3217e52cd5364684b8a295357187a53a26e437.tar.gz
gnu: rust-glob-0.3: Don't hide package.
* gnu/packages/crates-io.scm (rust-glob-0.3)[arguments]: Skip build. Add
rust-tempdir-0.3 to cargo-development-inputs.
[properties]: Remove field.
-rw-r--r--gnu/packages/crates-io.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ebc2afeae3..bb073700c7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3807,12 +3807,15 @@ reading and writing git repositories.")
          (base32
           "0x25wfr7vg3mzxc9x05dcphvd3nwlcmbnxrvwcvrrdwplcrrk4cv"))))
     (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-development-inputs
+       (("rust-tempdir" ,rust-tempdir-0.3))))
     (home-page "https://github.com/rust-lang-nursery/glob")
     (synopsis "Match file paths against Unix shell style patterns")
     (description
      "This package provides support for matching file paths against Unix
 shell style patterns.")
-    (properties '((hidden? . #t)))
     (license (list license:asl2.0
                    license:expat))))
 
@@ -3828,12 +3831,7 @@ shell style patterns.")
         (file-name (string-append name "-" version ".crate"))
         (sha256
          (base32
-          "1ysvi72slkw784fcsymgj4308c3y03gwjjzqxp80xdjnkbh8vqcb"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-development-inputs
-       (("rust-tempdir" ,rust-tempdir-0.3))))
-    (properties '())))
+          "1ysvi72slkw784fcsymgj4308c3y03gwjjzqxp80xdjnkbh8vqcb"))))))
 
 (define-public rust-globset-0.4
   (package