summary refs log tree commit diff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-11-05 08:07:58 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-11-05 10:23:24 +0100
commit5aa22d6ff98f101e1b64b9ac8dfbc9f452fc5f18 (patch)
treeab96be2a22783cfc95717958b3474cb9ab8c7b91
parent2f4071b0b2818d0856073203c1a86cb93a703f29 (diff)
downloadguix-5aa22d6ff98f101e1b64b9ac8dfbc9f452fc5f18.tar.gz
gnu: python-dateparser: Update to 1.1.3.
* gnu/packages/python-xyz.scm (python-dateparser): Update to 1.1.3.
[build-system]: Use pyproject-build-system.
[native-inputs]: Add ‘python-flake8’.  Remove ‘python-mock’.
[arguments]<#:tests?>: Remove argument.
<#:phases>: Add ‘delete-failing-tests’.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 19bbea7d42..75e1dcc0cb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27127,31 +27127,37 @@ It adds a simple and readable way to print stuff during development.")
 (define-public python-dateparser
   (package
     (name "python-dateparser")
-    (version "0.7.6")
+    (version "1.1.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "dateparser" version))
        (sha256
         (base32
-         "1ypbyqxlk7n6zibk90js3ybz37xmin3kk0i35g8c51bwqpcfyxg8"))))
-    (build-system python-build-system)
+         "19fbgq1zrwx10kljmdbs3p0y2m2xsgww20pqzw4kv6161zipsymf"))))
+    (build-system pyproject-build-system)
     (propagated-inputs
      (list python-dateutil python-pytz python-regex python-ruamel.yaml
            python-tzlocal))
     (native-inputs
-     (list python-mock python-parameterized tzdata-for-tests))
+     (list python-flake8 python-pytest python-parameterized tzdata-for-tests))
     (arguments
-     `(;; TODO: Of 23320 tests, 6 fail and 53 error.
-       #:tests? #f
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          (add-before 'check 'set-check-environment
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "TZ" "UTC")
              (setenv "TZDIR"
                      (search-input-directory inputs
-                                             "share/zoneinfo")))))))
+                                             "share/zoneinfo"))))
+         (add-before 'check 'delete-failing-tests
+           (lambda _
+             (with-directory-excursion "tests"
+               (for-each delete-file
+                         '("test_dateparser_data_integrity.py"
+                           "test_hijri.py"
+                           "test_jalali.py"
+                           "test_language_detect.py"))))))))
     (home-page "https://github.com/scrapinghub/dateparser")
     (synopsis
      "Date parsing library designed to parse dates from HTML pages")