summary refs log tree commit diff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-08 15:08:34 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:28 +0800
commit5b36e4a8923ed558c85fb826102070ac03a6cc2f (patch)
tree3b492956f94b2eb4bb0e6aad38af0b6d066b75ac
parentdc3e2505b9ecaeb9f42faacbe94fcc61e583ef52 (diff)
downloadguix-5b36e4a8923ed558c85fb826102070ac03a6cc2f.tar.gz
gnu: Add krunner-5.
* gnu/packages/kde-frameworks.scm (krunner-5): New variable.

Change-Id: If52e297261b69fbcead72fe1750f476efd6ee093
-rw-r--r--gnu/packages/kde-frameworks.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 62535bf774..6ed3dc42d2 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -4133,6 +4133,67 @@ various actions and information that match the text appear as the text is being
 typed.")
     (license license:lgpl2.1+)))
 
+(define-public krunner-5
+  (package
+    (inherit krunner)
+    (name "krunner")
+    (version "5.116.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0h889a4bj7vqhvy9hkqxd9v437zly73phyav10gv5b2l8fgb4zxq"))))
+    (propagated-inputs
+     (list plasma-framework))
+    (native-inputs
+     (list extra-cmake-modules
+           ;; For tests.
+           dbus))
+    (inputs
+     (list kactivities
+           kauth-5
+           kbookmarks-5
+           kcodecs-5
+           kcompletion-5
+           kconfig-5
+           kconfigwidgets-5
+           kcoreaddons-5
+           kio-5
+           kitemviews-5
+           ki18n-5
+           kjobwidgets-5
+           kpackage-5
+           kservice-5
+           kwidgetsaddons-5
+           kwindowsystem-5
+           kxmlgui-5
+           qtdeclarative-5
+           solid-5
+           threadweaver-5))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-paths-for-test
+            ;; This test tries to access paths like /home, /usr/bin and /bin/ls
+            ;; which don't exist in the build-container. Change to existing paths.
+            (lambda* (#:key inputs #:allow-other-keys)
+              (substitute* "autotests/runnercontexttest.cpp"
+                (("/home\"") "/tmp\"") ;; single path-part
+                (("//usr/bin\"") (string-append (getcwd) "\"")) ;; multiple path-parts
+                (("/bin/ls")
+                 (search-input-file inputs "/bin/ls")))))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (setenv "HOME" (getcwd))
+                (setenv "QT_QPA_PLATFORM" "offscreen")
+                (invoke "dbus-launch" "ctest")))))))))
+
 (define-public kservice
   (package
     (name "kservice")