summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-19 19:07:32 +0100
committerMarius Bakke <marius@gnu.org>2022-11-19 22:07:33 +0100
commit5c9164d5fbd6396edfa433ca19a4da84a7ce45eb (patch)
treecaf7d07abd9ecac80e0ab8c294a923cd2cd77082
parentfceeed3946a7c85bb755f9b2d7cf5e0c19ea47cd (diff)
downloadguix-5c9164d5fbd6396edfa433ca19a4da84a7ce45eb.tar.gz
gnu: mia: Fix build with VTK 9.2.
* gnu/packages/patches/mia-vtk92.patch,
gnu/packages/patches/mia-vtk-version.patch: New files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/image-processing.scm (mia)[source](patches): Add them.
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/image-processing.scm4
-rw-r--r--gnu/packages/patches/mia-vtk-version.patch15
-rw-r--r--gnu/packages/patches/mia-vtk92.patch14
4 files changed, 34 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index caf2fc69e3..e51453aba9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1538,6 +1538,8 @@ dist_patch_DATA =						\
   %D%/packages/patches/mhash-keygen-test-segfault.patch		\
   %D%/packages/patches/mia-fix-boost-headers.patch		\
   %D%/packages/patches/mia-vtk9.patch				\
+  %D%/packages/patches/mia-vtk92.patch				\
+  %D%/packages/patches/mia-vtk-version.patch			\
   %D%/packages/patches/mingw-w64-6.0.0-gcc.patch		\
   %D%/packages/patches/mingw-w64-dlltool-temp-prefix.patch	\
   %D%/packages/patches/mingw-w64-reproducible-gendef.patch	\
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 24282b5ad5..2c2cea1fac 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -201,7 +201,9 @@ licences similar to the Modified BSD licence."))))
                (base32
                 "0qpcd3n26q52dpyibm11f5l6cgscdr54p2jish39gc3p1f5h3ws1"))
               (patches (search-patches "mia-fix-boost-headers.patch"
-                                       "mia-vtk9.patch"))))
+                                       "mia-vtk9.patch"
+                                       "mia-vtk92.patch"
+                                       "mia-vtk-version.patch"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags
diff --git a/gnu/packages/patches/mia-vtk-version.patch b/gnu/packages/patches/mia-vtk-version.patch
new file mode 100644
index 0000000000..2435079dcc
--- /dev/null
+++ b/gnu/packages/patches/mia-vtk-version.patch
@@ -0,0 +1,15 @@
+The VTK_MAJOR_VERSION macro is not available by default in newer versions.
+This is a hack to expose it without changing all imports.
+
+diff --git a/addons/vtk/CMakeLists.txt b/addons/vtk/CMakeLists.txt
+--- a/addons/vtk/CMakeLists.txt
++++ b/addons/vtk/CMakeLists.txt
+@@ -36,6 +36,8 @@ IF(WITH_VTKIO)
+     ELSE()
+       SET(SELECTED_VTK_LIBS ${VTK_MODULES_REQUESTED})
+     ENDIF()
++
++   add_compile_definitions(VTK_MAJOR_VERSION=${VTK_VERSION_MAJOR})
+     
+     SET(VTK_LINK_LIBS_MESH ${SELECTED_VTK_LIBS} miamesh)
+     SET(VTK_LINK_LIBS_3D ${SELECTED_VTK_LIBS} mia3d)
diff --git a/gnu/packages/patches/mia-vtk92.patch b/gnu/packages/patches/mia-vtk92.patch
new file mode 100644
index 0000000000..afcb14e564
--- /dev/null
+++ b/gnu/packages/patches/mia-vtk92.patch
@@ -0,0 +1,14 @@
+Boolean pixel values are no longer supported in VTK 9.2.
+
+diff --git a/addons/vtk/test_vtkimage.cc b/addons/vtk/test_vtkimage.cc
+--- a/addons/vtk/test_vtkimage.cc
++++ b/addons/vtk/test_vtkimage.cc
+@@ -206,7 +206,7 @@ BOOST_AUTO_TEST_CASE_TEMPLATE( test_mhd_write_read, T, type_mhd )
+        unlink(zrawfilename.str().c_str());
+ }
+ 
+-#if  VTK_MAJOR_VERSION >= 7
++#if  VTK_MAJOR_VERSION >= 7 && VTK_MAJOR_VERSION < 9
+ BOOST_AUTO_TEST_CASE( test_simple_write_read_bool )
+ {
+        C3DBounds size(2, 3, 4);