summary refs log tree commit diff
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2020-12-08 02:46:42 +0000
committerLudovic Courtès <ludo@gnu.org>2020-12-14 12:20:09 +0100
commit5cac753d88cf7d8721039887ceba12aff164449f (patch)
tree0c4af67a0e07a7774073b3513567d1cf3bc31eae
parent7a8a4fd7a73f81d99e293ae9f2c70357524beba1 (diff)
downloadguix-5cac753d88cf7d8721039887ceba12aff164449f.tar.gz
gnu: b4: Update to 0.6.1.
* gnu/packages/version-control.scm (b4): Update to 0.6.1.
[source]: Download from pypi, which now includes the manpage.
[arguments]: Remove now unnecessary install-manpages phase.
[inputs]: Add python-dkimpy and python-dnspython.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/version-control.scm28
1 files changed, 8 insertions, 20 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 8504c8b006..d20cf7e655 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2318,31 +2318,19 @@ based on a manifest file published by servers.")
 (define-public b4
   (package
     (name "b4")
-    (version "0.5.3")
+    (version "0.6.1")
     (source
      (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://git.kernel.org/pub/scm/utils/b4/b4.git")
-             (commit (string-append "v" version))))
-       (file-name (string-append name "-" version "-checkout"))
+       (method url-fetch)
+       (uri (pypi-uri "b4" version))
        (sha256
-        (base32 "0bnjs758blll2i70r4qh3khma7dly5lb8s6kzn5a3p54md91s8v5"))))
+        (base32 "01qid6mvddikcdpf2ihsyn8x3z5j2n64g0ip9pqbx42hrc50pmcz"))))
     (build-system python-build-system)
-    (arguments
-     `(#:tests? #f                      ; No tests.
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'install-manpages
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((man (string-append (assoc-ref outputs "out")
-                                       "/man/man5/")))
-               (mkdir-p man)
-               (for-each (lambda (file) (install-file file man))
-                         (find-files "man" "\\.[1-8]$")))
-             #t)))))
+    (arguments '(#:tests? #f))          ; No tests.
     (inputs
-     `(("python-requests" ,python-requests)))
+     `(("python-dkimpy" ,python-dkimpy)
+       ("python-dnspython" ,python-dnspython)
+       ("python-requests" ,python-requests)))
     (home-page "https://git.kernel.org/pub/scm/utils/b4/b4.git")
     (synopsis "Tool for working with patches in public-inbox archives")
     (description