summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolò Balzarotti <anothersms@gmail.com>2019-12-11 10:00:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-11 12:06:41 +0100
commit5d387030e8ccc87234a1197cb2bb9fdac1b074ee (patch)
tree1c8ea14a98c45bbb8c37de668d451e2582b89d74
parente87b83b62c2d21e0efc4ae62a115405aeef756a6 (diff)
downloadguix-5d387030e8ccc87234a1197cb2bb9fdac1b074ee.tar.gz
gnu: Add r-statcheck.
* gnu/packages/cran.scm (r-statcheck): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 11d254001f..839f6360b5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4168,6 +4168,30 @@ supports arbitrary vertex/edge/graph attributes.")
 software developed by the Statnet Project.")
     (license license:gpl3)))
 
+(define-public r-statcheck
+  (package
+    (name "r-statcheck")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "statcheck" version))
+       (sha256
+        (base32
+         "0ivybdcrymlsfv6pg6p5bv70qdvgxf2vgp0kf4r0pf2fcvav1mcp"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-plyr" ,r-plyr)
+       ("r-rmarkdown" ,r-rmarkdown)))
+    (home-page "https://cran.r-project.org/web/packages/statcheck/")
+    (synopsis "Extract statistics from articles and recompute p-values")
+    (description "This package can automatically extract statistical
+null-hypothesis significant testing (NHST) results from articles and recompute
+the p-values based on the reported test statistic and degrees of freedom to
+detect possible inconsistencies.")
+    (license license:gpl2)))
+
 (define-public r-sna
   (package
     (name "r-sna")