summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-10-14 19:27:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-15 21:07:24 +0200
commit5d58d2068423e2358044737fc27e5c4b875a5d20 (patch)
treedda478c7cb1e8f130a66b9790c2bf173a8670ffa
parent1682aba2473642f9b282916e4b8f3a1cdb3f35fc (diff)
downloadguix-5d58d2068423e2358044737fc27e5c4b875a5d20.tar.gz
gnu: Add r-macrophage.
X-Debbugs-Cc: rekado@elephly.net

* gnu/packages/bioconductor.scm (r-macrophage): New variable.
-rw-r--r--gnu/packages/bioconductor.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ecb60f2e24..3692bb94af 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1384,6 +1384,29 @@ genomation package.  Included are Chip Seq, Methylation and Cage data,
 downloaded from Encode.")
     (license license:gpl3+)))
 
+(define-public r-macrophage
+  (package
+    (name "r-macrophage")
+    (version "1.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "macrophage" version
+                                     'experiment))
+              (sha256
+               (base32
+                "0ml8v92w021fmzsn4yl90ap3l4l3b9c1pk8pzsrm122p82wzlyms"))))
+    (properties `((upstream-name . "macrophage")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/macrophage")
+    (synopsis "Human macrophage immune response data")
+    (description
+     "This package provides the output of running @code{Salmon} on a set of 24
+RNA-seq samples from Alasoo, et al. \"Shared genetic effects on chromatin and
+gene expression indicate a role for enhancer priming in immune response\", published
+in Nature Genetics, January 2018.")
+    (license license:gpl2+)))
+
 (define-public r-msdata
   (package
     (name "r-msdata")