summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-14 11:24:10 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:16 -0400
commit5d8fb87127beee50671a9506013be541a8b45ea8 (patch)
treebff87cbc2b042dcfc6e3000e6c441a8c6c6cd47a
parent026fca8b5b30aaa584e3c2b8144bf21a882a5edd (diff)
downloadguix-5d8fb87127beee50671a9506013be541a8b45ea8.tar.gz
gnu: Remove python2-setuptools.
* gnu/packages/python-xyz.scm (python2-setuptools): Delete variable.
(python-setuptools)[properties]: Delete field.
* gnu/packages/syncthing.scm (syncthing-gtk): Delete commented native input.
* guix/lint.scm (check-inputs-should-not-be-an-input-at-all): Remove obsolete entries.
-rw-r--r--gnu/packages/python-xyz.scm57
-rw-r--r--gnu/packages/syncthing.scm2
-rw-r--r--guix/lint.scm4
3 files changed, 1 insertions, 62 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0435b2c7f4..d59d353009 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1843,63 +1843,6 @@ facilitate packaging Python projects, where packaging includes:
     (license (list license:psfl         ;setuptools itself
                    license:expat        ;six, appdirs, pyparsing
                    license:asl2.0       ;packaging is dual ASL2/BSD-2
-                   license:bsd-2))
-    (properties `((python2-variant . ,(delay python2-setuptools))))))
-
-;; Newer versions of setuptools no longer support Python 2.
-(define-public python2-setuptools
-  (package
-    (name "python2-setuptools")
-    (version "41.0.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "setuptools" version ".zip"))
-       (sha256
-        (base32
-         "04sns22y2hhsrwfy1mha2lgslvpjsjsz8xws7h2rh5a7ylkd28m2"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           ;; Remove included binaries which are used to build self-extracting
-           ;; installers for Windows.
-           ;; TODO: Find some way to build them ourself so we can include them.
-           (for-each delete-file (find-files "setuptools" "^(cli|gui).*\\.exe$"))
-           #t))))
-    (build-system python-build-system)
-    ;; FIXME: Tests require pytest, which itself relies on setuptools.
-    ;; One could bootstrap with an internal untested setuptools.
-    (arguments
-     `(#:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'compatibility-fixes
-           (lambda _
-             ;; HTMLParser no longer exists.
-             (substitute* "setuptools/py33compat.py"
-               (("html_parser.HTMLParser\\(\\).unescape")
-                "html.unescape"))
-             ;; This needs distutils.msvc9compiler
-             (delete-file "setuptools/tests/test_msvc.py"))))))
-    (native-inputs
-     (list unzip))
-    (home-page "https://pypi.org/project/setuptools/")
-    (synopsis
-     "Library designed to facilitate packaging Python projects")
-    (description
-     "Setuptools is a fully-featured, stable library designed to facilitate
-packaging Python projects, where packaging includes:
-Python package and module definitions,
-distribution package metadata,
-test hooks,
-project installation,
-platform-specific details,
-Python 3 support.")
-    ;; TODO: setuptools now bundles the following libraries:
-    ;; packaging, pyparsing, six and appdirs. How to unbundle?
-    (license (list license:psfl         ; setuptools itself
-                   license:expat        ; six, appdirs, pyparsing
-                   license:asl2.0       ; packaging is dual ASL2/BSD-2
                    license:bsd-2))))
 
 (define-public python-setuptools-declarative-requirements
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 6002c10560..4dfa62c017 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -202,8 +202,6 @@ Protocol.")
              python-pygobject
              psmisc
              syncthing))
-      ;; (native-inputs
-      ;;  `(("python2-setuptools" ,python2-setuptools)))
       (home-page "https://github.com/syncthing/syncthing-gtk")
       (synopsis "GTK3 based GUI and notification area icon for Syncthing")
       (description "@code{syncthing-gtk} is a GTK3 Python based GUI and
diff --git a/guix/lint.scm b/guix/lint.scm
index aa16efe6db..73581b518f 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -523,9 +523,7 @@ of a package, and INPUT-NAMES, a list of package specifications such as
   ;; Emit a warning if some inputs of PACKAGE are likely to should not be
   ;; an input at all.
   (let ((input-names '("python-setuptools"
-                       "python2-setuptools"
-                       "python-pip"
-                       "python2-pip")))
+                       "python-pip")))
     (map (lambda (input)
            (make-warning
             package