summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-07 20:12:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-07 22:18:38 +0100
commit5d9b82acfc597edfcf8ae0cce0f897c3764bb9b9 (patch)
tree63be41a22b8b242efb0accc66cf68acc0f19281b
parenta00968b7a878ab5aa0d0afb000f29e713b880674 (diff)
downloadguix-5d9b82acfc597edfcf8ae0cce0f897c3764bb9b9.tar.gz
gnu: Add r-shinyace.
* gnu/packages/cran.scm (r-shinyace): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b256d228d8..d0033e1685 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2826,3 +2826,25 @@ imports.  Furthermore the imported objects are not placed in the current
 environment.  It is also possible to import objects from stand-alone @code{.R}
 files.")
     (license license:expat)))
+
+(define-public r-shinyace
+  (package
+    (name "r-shinyace")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "shinyAce" version))
+       (sha256
+        (base32
+         "0ycka8rsw0178q9klfid97vdn5cbyx3r778nis5s3dqipdyazdm9"))))
+    (properties `((upstream-name . "shinyAce")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-shiny" ,r-shiny)))
+    (home-page "http://cran.r-project.org/web/packages/shinyAce")
+    (synopsis "Ace editor bindings for Shiny")
+    (description
+     "This package provides Ace editor bindings to enable a rich text editing
+environment within Shiny.")
+    (license license:expat)))