summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:11 +0200
commit5e3a351ba1d1c754494523ca74591a3da024d9af (patch)
tree249a0d1dca19b8345ed7866641dd9cac720229e3
parent4cb07af4c9c6d75395beed2eb4d9a4cfd27d2210 (diff)
downloadguix-5e3a351ba1d1c754494523ca74591a3da024d9af.tar.gz
gnu: Add texlive-unicodefonttable.
* gnu/packages/tex.scm (texlive-unicodefonttable): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dabd474652..8468b7e250 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98948,6 +98948,30 @@ titlepage styles with several standard elements, and optionally additional
 elements.")
     (license license:lppl1.3c)))
 
+(define-public texlive-unicodefonttable
+  (package
+    (name "texlive-unicodefonttable")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/unicodefonttable/"
+                   "source/latex/unicodefonttable/"
+                   "tex/latex/unicodefonttable/")
+             (base32
+              "1r1z89bcc48kzz4sms1sp0gvbrssq5s949b5srcyf2rmw1a4g93f")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/unicodefonttable")
+    (synopsis "Unicode font table generator")
+    (description
+     "This package produces font tables for Unicode fonts as well as for 8-bit fonts.
+The table layout can be adjusted in various ways including restricting the
+range of output to show only a portion of a specific font.  To quickly produce
+a one-off table there is a stand-alone version @file{unicodefont.tex} that
+asks you a few questions and then generates the table --- somewhat similar to
+@file{nfssfont.tex} for 8-bit fonts.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar