summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-09-19 03:37:11 +0530
committerArun Isaac <arunisaac@systemreboot.net>2022-10-15 11:56:14 +0530
commit5f414c8edbd9ef8a00ca1ab53ab97cda55e4c516 (patch)
treeadeb04dee5b1037d496f92761c8377cc56212af4
parent4dfaddfc44d3a05db7ad9720b8d8942aec3a1d7f (diff)
downloadguix-5f414c8edbd9ef8a00ca1ab53ab97cda55e4c516.tar.gz
gnu: font-ibm-plex: Use git source.
* gnu/packages/fonts.scm (font-ibm-plex)[source]: Use git source.
-rw-r--r--gnu/packages/fonts.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 2d653abf32..63f274e59d 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -118,14 +118,18 @@ titling.")
   (package
     (name "font-ibm-plex")
     (version "6.1.1")
+    ;; We prefer git-fetch since it lets us get the opentype, truetype and web
+    ;; fonts all in one download. The zip archive releases separate the
+    ;; opentype, truetype and web fonts into three separate archives.
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/IBM/plex/releases/download/"
-                    "v" version "/OpenType.zip"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/IBM/plex")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1z9nxac9ha6gqz5yvfy5lp6hyl39f8f8hdrw3llcp89rdpjfqdn9"))))
+                "1jxyd0zl7jssn7mwz8x5xvjmw59x4mn82s2kywf9583k1pg949k1"))))
     (build-system font-build-system)
     (home-page "https://github.com/IBM/plex")
     (synopsis "IBM Plex typeface")