summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 15:01:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 15:20:59 +0200
commit5fb91c1f7237858e7f0b2163e2957fe2a544c73d (patch)
tree0ac76f36482097f556c2ffac4ce93d28649fdd86
parent163caea91678362e96c71cdda64b7f96e38159dd (diff)
downloadguix-5fb91c1f7237858e7f0b2163e2957fe2a544c73d.tar.gz
gnu: Add texlive-churchslavonic.
* gnu/packages/tex.scm (texlive-churchslavonic): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f2bc78e9ec..d0568ff707 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3086,6 +3086,31 @@ leading journals.  It also provides some handy chemistry-related macros.")
 Interfaces for Plain TeX, ConTeXt and LaTeX are provided.")
     (license license:lppl1.3+)))
 
+(define-public texlive-churchslavonic
+  (package
+    (name "texlive-churchslavonic")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/churchslavonic/"
+                   "tex/latex/churchslavonic/")
+             (base32
+              "1qyxyp0ckizrryvqyz8cz066g9vvz01ki6b50sm5hk44b6b4v3ri")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-etoolbox
+           texlive-fonts-churchslavonic
+           texlive-hyphen-complete
+           texlive-oberdiek
+           texlive-xcolor))
+    (home-page "https://ctan.org/pkg/churchslavonic")
+    (synopsis "Typeset documents in Church Slavonic language using Unicode")
+    (description
+     "The package provides fonts, hyphenation patterns, and supporting macros
+to typeset Church Slavonic texts.")
+    (license license:expat)))
+
 (define-public texlive-clrscode
   (package
     (name "texlive-clrscode")