summary refs log tree commit diff
diff options
context:
space:
mode:
authorCayetano Santos <csantosb@inventati.org>2023-08-21 09:46:34 +0200
committerLudovic Courtès <ludo@gnu.org>2023-09-11 23:54:50 +0200
commit5ff9afb5fdc6e34936683524907343859976a805 (patch)
tree75bdfaf3e27bf0c62e7581bc56f76a537ed766d8
parent3235bfa25a82c1dbe6a8a0ec83ae98f840d1deb4 (diff)
downloadguix-5ff9afb5fdc6e34936683524907343859976a805.tar.gz
gnu: emacs-mastodon: Update to 1.0.0-1.20dec88.
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.0-1.20dec88.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm63
1 files changed, 33 insertions, 30 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a380abc4ed..6063dc8958 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32794,37 +32794,40 @@ time.")
     (license license:gpl3+)))
 
 (define-public emacs-mastodon
-  (package
-    (name "emacs-mastodon")
-    (version "1.0.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://codeberg.org/martianh/mastodon.el")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "13swcbvwhjl8ksrgzvmfafkgd3iz8znk49bs1n48w3g9qvh097w7"))))
-    (build-system emacs-build-system)
-    (arguments
-     (list #:phases
-           #~(modify-phases %standard-phases
-               ;; Move the source files to the top level, which is included in
-               ;; the EMACSLOADPATH.
-               (add-after 'unpack 'move-source-files
-                 (lambda _
-                   (let ((el-files (find-files "./lisp" ".*\\.el$")))
-                     (for-each (lambda (f)
-                                 (rename-file f (basename f)))
-                               el-files)))))))
-    (propagated-inputs
-     (list emacs-request))
-    (home-page "https://codeberg.org/martianh/mastodon.el")
-    (synopsis "Emacs client for Mastodon")
-    (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+  ;; No release in ~1 year, hence this snapshot.
+  (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
+        (revision "1"))
+    (package
+      (name "emacs-mastodon")
+      (version (git-version "1.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://codeberg.org/martianh/mastodon.el")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
+      (build-system emacs-build-system)
+      (arguments
+       (list #:phases
+             #~(modify-phases %standard-phases
+                 ;; Move the source files to the top level, which is included in
+                 ;; the EMACSLOADPATH.
+                 (add-after 'unpack 'move-source-files
+                   (lambda _
+                     (let ((el-files (find-files "./lisp" ".*\\.el$")))
+                       (for-each (lambda (f)
+                                   (rename-file f (basename f)))
+                                 el-files)))))))
+      (propagated-inputs
+       (list emacs-request emacs-ts emacs-persist))
+      (home-page "https://codeberg.org/martianh/mastodon.el")
+      (synopsis "Emacs client for Mastodon")
+      (description "@code{mastodon.el} is an Emacs client for Mastodon, the
 federated microblogging social network.")
-    (license license:gpl3+)))
+	  (license license:gpl3+))))
 
 (define-public emacs-ebdb
   (package