summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:54:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:40 +0200
commit6090dd9635cc99b6a366dbbde16250cefcd3bf9a (patch)
tree0231a41005a00d3e21e7ed54a537db7d5c8d5098
parentcec56f84b63c4ea78a6a9e431f0420c29a946cbf (diff)
downloadguix-6090dd9635cc99b6a366dbbde16250cefcd3bf9a.tar.gz
gnu: Add texlive-raleway.
* gnu/packages/tex.scm (texlive-raleway): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f2fd369556..9ecbf79b63 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -22065,6 +22065,32 @@ use.  Quattrocento Sans is the perfect sans-serif companion for
 Quattrocento.")
     (license (list license:silofl1.1 license:lppl))))
 
+(define-public texlive-raleway
+  (package
+    (name "texlive-raleway")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/raleway/"
+                   "fonts/enc/dvips/raleway/"
+                   "fonts/map/dvips/raleway/"
+                   "fonts/opentype/impallari/raleway/"
+                   "fonts/tfm/impallari/raleway/"
+                   "fonts/type1/impallari/raleway/"
+                   "fonts/vf/impallari/raleway/"
+                   "tex/latex/raleway/")
+             (base32
+              "1pp5m31rr4lww0z92q3vsaz1l01nb78ll5mn2l9w469hpghf2gd3")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/raleway")
+    (synopsis "Use Raleway with TeX(-alike) systems")
+    (description
+     "The package provides the Raleway family in an easy to use way.  For
+XeLaTeX and LuaLaTeX users the original OpenType fonts are used.  The entire
+font family is included.")
+    (license license:silofl1.1)))
+
 (define-public texlive-rank-2-roots
   (package
     (name "texlive-rank-2-roots")