summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-01-17 22:48:48 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-01-17 22:48:48 +0100
commit60ceff7ef530dd9ac8d9e9e65dfead0f3b8a22f8 (patch)
treeefa4f26e3006af19839408d194d3efcd47259019
parentcac00bbd979cf914ca928f096c2bef253cb6af9f (diff)
downloadguix-60ceff7ef530dd9ac8d9e9e65dfead0f3b8a22f8.tar.gz
gnu: Add emacs-anaphora.
* gnu/packages/emacs-xyz.scm (emacs-anaphora): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a12a4e26f7..e4f80454a2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -681,6 +681,31 @@ can take association lists, hash tables, and in some cases vectors (where the
 index is considered the key).")
     (license license:gpl3+)))
 
+(define-public emacs-anaphora
+  (package
+    (name "emacs-anaphora")
+    (version "1.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rolandwalker/anaphora.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "11fgiy029sqz7nvdm7dcal95lacryz9zql0x5h05z48nrrcl4bib"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/rolandwalker/anaphora/")
+    (synopsis "Anaphoric expressions for Emacs Lisp")
+    (description "@code{emacs-anaphora} implements anaphoric expressions for
+Emacs Lisp.
+
+Anaphoric expressions implicitly create one or more temporary variables which
+can be referred to during the expression.  This technique can improve clarity
+in certain cases.  It also enables recursion for anonymous functions.")
+    (license license:public-domain)))
+
 
 ;;;
 ;;; Web browsing.