summary refs log tree commit diff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-08 14:58:28 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-14 14:41:26 +0100
commit61078f0f94fc3e3c6ab0a250049799adb08542c6 (patch)
tree1f222ad98dcaa279189ebcca11887b862b01970a
parent7cb4c5211f174ffe5fa9b0bde6d34cfc38cf0a0d (diff)
downloadguix-61078f0f94fc3e3c6ab0a250049799adb08542c6.tar.gz
gnu: Add perl-crypt-unixcrypt_xs.
* gnu/packages/perl.scm (perl-crypt-unixcrypt_xs): New variable.
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 35c59cce7d..f3912c2775 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1966,6 +1966,29 @@ supported encryption modes are:
     (description "A pure Perl implementation of the RC4 algorithm.")
     (license (package-license perl))))
 
+(define-public perl-crypt-unixcrypt_xs
+  (package
+    (name "perl-crypt-unixcrypt_xs")
+    (version "0.11")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append
+            "mirror://cpan/authors/id/B/BO/BORISZ/Crypt-UnixCrypt_XS-"
+            version ".tar.gz"))
+      (sha256
+       (base32
+        "1ajg3x6kwxy4x9p3nw1j36qjxpjvdpi9wkca5gfd86y9q8939sv2"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/Crypt-UnixCrypt_XS")
+    (synopsis "XS interface for a portable traditional crypt function")
+    (description "@code{Crypt::UnixCrypt_XS} implements the DES-based
+Unix @code{crypt} function.  For those who need to construct
+non-standard variants of @code{crypt}, the various building blocks
+used in @code{crypt} are also supplied separately.")
+    ;; Files in the 'fcrypt' directory are covered by a BSD licence.
+    (license (list perl-license bsd-3))))
+
 (define-public perl-cwd-guard
   (package
     (name "perl-cwd-guard")