summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:19:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:51 +0200
commit617ea6378d1e11807ba4090ae1599d6af926d66e (patch)
tree7105af11785734b123c0965ad1b98bafe848cd20
parent7a160cdacb92654cfbbdac59af064089650f7fd0 (diff)
downloadguix-617ea6378d1e11807ba4090ae1599d6af926d66e.tar.gz
gnu: Add texlive-navydocs.
* gnu/packages/tex.scm (texlive-navydocs): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8aee07a4ad..bac6e847ac 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -22644,6 +22644,29 @@ This class and BibTeX style provide what seems to be necessary to produce
 papers in a format acceptable to the publisher.")
     (license license:lppl)))
 
+(define-public texlive-navydocs
+  (package
+    (name "texlive-navydocs")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/navydocs/"
+                   "source/latex/navydocs/"
+                   "tex/latex/navydocs/")
+             (base32
+              "1qisck3lr1nhjnqs195agvmiw93yld801nahr3bb7yyhzgn2f443")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/navydocs")
+    (synopsis "Support for technical reports by US Navy organizations")
+    (description
+     "The @code{navydocs} package provides an easy means for creating title
+pages and the following supplementary material pages used in technical reports
+by United States Navy organizations.  These pages are generated by specifying
+the page content via a set of commands and then calling a macro to create the
+page at its occurence in the document.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-nchairx
   (package
     (name "texlive-nchairx")