summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:38:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:22 +0200
commit622db1c5c725b530f5243228e23db7f5381c8820 (patch)
tree5d00f6f4d7c4e5f073e868d8055d29c58c51c433
parent8e0cb84ef710d195b5e9f785a1d32bdad3c46892 (diff)
downloadguix-622db1c5c725b530f5243228e23db7f5381c8820.tar.gz
gnu: Add texlive-librebaskerville.
* gnu/packages/tex.scm (texlive-librebaskerville): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bd6c1ca6c2..2687894157 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16539,6 +16539,33 @@ a math accompaniment to Libertine under LaTeX.  In addition, with option
 Roman and Greek letters.")
     (license (list license:silofl1.1 license:lppl))))
 
+(define-public texlive-librebaskerville
+  (package
+    (name "texlive-librebaskerville")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/librebaskerville/"
+                   "fonts/enc/dvips/librebaskerville/"
+                   "fonts/map/dvips/librebaskerville/"
+                   "fonts/tfm/impallari/librebaskerville/"
+                   "fonts/truetype/impallari/librebaskerville/"
+                   "fonts/type1/impallari/librebaskerville/"
+                   "fonts/vf/impallari/librebaskerville/"
+                   "tex/latex/librebaskerville/")
+             (base32
+              "1rjac2w8q0m4a6qcdjphv3rgws19vbg65wv6gk1frl0d14bijqdy")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/librebaskerville")
+    (synopsis "Libre Baskerville family of fonts with LaTeX support")
+    (description
+     "This package provides the Libre Baskerville family of fonts, designed by
+Pablo Impallari, for use with LaTeX, pdfLaTeX, XeLaTeX or LuaLaTeX.  It is
+primarily intended to be a web font but is also attractive as a text font.
+A BoldItalic variant has been artificially generated.")
+    (license (list license:silofl1.1 license:lppl))))
+
 (define-public texlive-lie-hasse
   (package
     (name "texlive-lie-hasse")