summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 11:41:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 11:44:33 +0200
commit62381dce865240b70c08e96f514009a8d62a338c (patch)
tree0bd146bb66a1c576e57e8fbb18092b4f1a4ded3e
parent4867738c7fc84b34b58b7c910ec0e573431ef8eb (diff)
downloadguix-62381dce865240b70c08e96f514009a8d62a338c.tar.gz
gnu: Add r-beclear.
* gnu/packages/bioconductor.scm (r-beclear): New variable.
-rw-r--r--gnu/packages/bioconductor.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ea8a885c5f..b2d687a5e6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -13733,6 +13733,39 @@ BAM files.  With this package, you can build base-pair coverage matrices for
 regions or annotations of your choice from BigWig files.")
     (license license:artistic2.0)))
 
+(define-public r-beclear
+  (package
+    (name "r-beclear")
+    (version "2.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BEclear" version))
+       (sha256
+        (base32
+         "0w18livng2gcmjgvws7pix3gsnj237rs34sgwxsfmn8p5vfx8b30"))))
+    (properties `((upstream-name . "BEclear")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-abind" ,r-abind)
+       ("r-biocparallel" ,r-biocparallel)
+       ("r-data-table" ,r-data-table)
+       ("r-futile-logger" ,r-futile-logger)
+       ("r-matrix" ,r-matrix)
+       ("r-outliers" ,r-outliers)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rdpack" ,r-rdpack)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/uds-helms/BEclear")
+    (synopsis "Correction of batch effects in DNA methylation data")
+    (description
+     "This package provides functions to detect and correct for batch effects
+in DNA methylation data.  The core function is based on latent factor models
+and can also be used to predict missing values in any other matrix containing
+real numbers.")
+    (license license:gpl3)))
+
 (define-public r-tximeta
   (package
     (name "r-tximeta")