summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-22 18:54:36 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-07-22 21:44:27 +0200
commit62879d22163af5b8dfe0f788de193ac1d0f9a66f (patch)
tree39a719f26b06b8dbdc4ca77802f6e2f21da2fe15
parent9630ae345bf165704eb0de47c788cb70f5bf0d53 (diff)
downloadguix-62879d22163af5b8dfe0f788de193ac1d0f9a66f.tar.gz
gnu: Add go-github-com-michiwend-gomusicbrainz.
* gnu/packages/golang.scm (go-github-com-michiwend-gomusicbrainz): New variable.
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d0b6c25502..25e6c44af1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2300,3 +2300,32 @@ It provides a function, @code{Formatter}, that can be used with any function
 that accepts a format string.  It also provides convenience wrappers for
 functions in packages @code{fmt} and @code{log}.")
       (license license:expat))))
+
+(define-public go-github-com-michiwend-gomusicbrainz
+  (let ((commit "0cdeb13f9b24d2c714feb7e3c63d595cf7121d7d")
+        (revision "0"))
+    (package
+      (name "go-github-com-michiwend-gomusicbrainz")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url
+                "https://github.com/michiwend/gomusicbrainz")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1li9daw0kghb80rdmxbh7g72qhxcvx3rvhwq5gs0jrr9hb8pjvcn"))))
+      (build-system go-build-system)
+      (native-inputs
+       `(("go-github-com-michiwend-golang-pretty" ,go-github-com-michiwend-golang-pretty)
+         ("go-github-com-kr-text" ,go-github-com-kr-text)))
+      (arguments
+       `(#:import-path "github.com/michiwend/gomusicbrainz"))
+      (home-page "https://github.com/michiwend/gomusicbrainz")
+      (synopsis "MusicBrainz WS2 client library for Golang")
+      (description "Currently GoMusicBrainz provides methods to perform search
+and lookup requests.  Browse requests are not supported yet.")
+      (license license:expat))))