summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-04-01 14:45:54 -0400
committerLeo Famulari <leo@famulari.name>2021-12-31 13:18:32 -0500
commit62f1dcc923654441e5bb5fed3366b1b120ebdb93 (patch)
treeebb1448b90b9d5d0bb027a9619cd1cf0e86412fb
parent60661adfb8ffa28e1acfcfea27c6cc2fc70f88fe (diff)
downloadguix-62f1dcc923654441e5bb5fed3366b1b120ebdb93.tar.gz
gnu: Add musikcube.
* gnu/packages/music.scm (musikcube): New variable.
-rw-r--r--gnu/packages/music.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 30dfe4ac73..a9c341ad5f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -121,6 +121,7 @@
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages gnunet)
   #:use-module (gnu packages gpodder)
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages graphviz)
@@ -132,6 +133,7 @@
   #:use-module (gnu packages imagemagick)
   #:use-module (gnu packages java)
   #:use-module (gnu packages libffi)
+  #:use-module (gnu packages libevent)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux) ; for alsa-utils
   #:use-module (gnu packages lirc)
@@ -6826,3 +6828,50 @@ editing modes.  Tags can be edited interactively with an editor of your
 choice.")
     (home-page "https://github.com/fmang/opustags")
     (license license:bsd-3)))
+
+(define-public musikcube
+  (package
+    (name "musikcube")
+    (version "0.96.10")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/clangen/musikcube/")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "06myr83x8jvzlzchg3jsw1163n2lcsbmb176zgnx7xxa26jpdbh1"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f ; No test suite
+       #:configure-flags
+       '("-DCMAKE_BUILD_TYPE=Release"
+         "-DENABLE_BUNDLED_TAGLIB=false"
+         ;; Use the "wide" ncurses headers but don't look for them in an
+         ;; ncursesw directory. For more info:
+         ;; https://github.com/clangen/musikcube/wiki/building#compiler-cannot-find-ncurseswcursesh
+         "-DNO_NCURSESW=true"
+         ;; We will strip the binaries ourselves in the 'strip' phase.
+         "-DDISABLE_STRIP=true")))
+    (native-inputs
+     (list pkg-config))
+    (inputs
+     (list alsa-lib
+           boost
+           curl
+           ffmpeg
+           lame
+           libev
+           libmicrohttpd
+           libopenmpt
+           ncurses
+           openssl
+           pulseaudio
+           taglib
+           zlib))
+    (synopsis "Terminal-based music player, library, and streaming audio server")
+    (description "Musikcube is a terminal-based music player, library, and
+streaming audio server.")
+    (home-page "https://musikcube.com/")
+    (license license:bsd-3)))