summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-22 12:16:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:09 +0200
commit639994711c3215d8d69c9432083005fecd5dca9b (patch)
treefeff8e8b1b8068e68f324d0d37b7008bcc21ced5
parent194e453135013be64c380221449d4545263d40f8 (diff)
downloadguix-639994711c3215d8d69c9432083005fecd5dca9b.tar.gz
gnu: rust-cordic-0.1: Update to 0.1.5.
* gnu/packages/crates-io.scm (rust-cordic-0.1): Update to 0.1.5.
[arguments]: Don't skip the build.

Change-Id: Ief3a795a8f3604cffd811a17cd662ada86f667e0
-rw-r--r--gnu/packages/crates-io.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7cf9130920..2d54890a5f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -13461,20 +13461,17 @@ contents of the OS-level clipboard.")
 (define-public rust-cordic-0.1
   (package
     (name "rust-cordic")
-    (version "0.1.4")
+    (version "0.1.5")
     (source
       (origin
         (method url-fetch)
         (uri (crate-uri "cordic" version))
-        (file-name
-         (string-append name "-" version ".tar.gz"))
+        (file-name (string-append name "-" version ".tar.gz"))
         (sha256
-         (base32
-          "13zvqn6c8d8lp18p9ik10q100wfsyv2m2n4fca16laq3yw7r231m"))))
+         (base32 "1l0jfhm6kynv61bp9ncmi25bdib40d9pfcajl1gwkidqq1va3l0f"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:skip-build? #t     ; rust-fixed fails to build
-       #:cargo-inputs (("rust-fixed" ,rust-fixed-1))))
+     `(#:cargo-inputs (("rust-fixed" ,rust-fixed-1))))
     (home-page "https://github.com/sebcrozet/cordic")
     (synopsis "Special functions for fixed-point numbers using the CORDIC method")
     (description "This package provides special functions for fixed-point