summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-13 00:48:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-13 01:19:53 +0200
commit63c8323ae9b9cf9cd9684a65bfacc05077c65583 (patch)
treea1e64eea10a55d991ff45107899371d9fc3c38ba
parent43fb14cedcf563824064f1d04240f0bbc68f267f (diff)
downloadguix-63c8323ae9b9cf9cd9684a65bfacc05077c65583.tar.gz
gnu: r-clusterprofiler: Update to 3.16.0.
* gnu/packages/bioconductor.scm (r-clusterprofiler): Update to 3.16.0.
[propagated-inputs]: Remove r-ggplot2; add r-downloader and r-dplyr.
[native-inputs]: Add r-knitr.
-rw-r--r--gnu/packages/bioconductor.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index dc4d1572ac..ffc72b1453 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3810,22 +3810,23 @@ All the visualization methods are developed based on ggplot2 graphics.")
 (define-public r-clusterprofiler
   (package
     (name "r-clusterprofiler")
-    (version "3.14.3")
+    (version "3.16.0")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "clusterProfiler" version))
        (sha256
         (base32
-         "08pd7bmqmyxncj09ilz8yb9sf1pv9ni98y8b93pz2giy7pl407hg"))))
+         "0m7919gzrd2fddb4kcznwpshhab1ha2yppnkxg11zmh40wcdawyi"))))
     (properties
      `((upstream-name . "clusterProfiler")))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-annotationdbi" ,r-annotationdbi)
        ("r-dose" ,r-dose)
+       ("r-downloader" ,r-downloader)
+       ("r-dplyr" ,r-dplyr)
        ("r-enrichplot" ,r-enrichplot)
-       ("r-ggplot2" ,r-ggplot2)
        ("r-go-db" ,r-go-db)
        ("r-gosemsim" ,r-gosemsim)
        ("r-magrittr" ,r-magrittr)
@@ -3833,6 +3834,8 @@ All the visualization methods are developed based on ggplot2 graphics.")
        ("r-qvalue" ,r-qvalue)
        ("r-rvcheck" ,r-rvcheck)
        ("r-tidyr" ,r-tidyr)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
     (home-page "https://guangchuangyu.github.io/software/clusterProfiler/")
     (synopsis "Analysis and visualization of functional profiles for gene clusters")
     (description