summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-08-05 18:26:12 -0300
committerVinicius Monego <monego@posteo.net>2023-08-05 18:40:01 -0300
commit645aeaf52dfae66506e382f632042bc7fa4643a2 (patch)
tree6e9a74330f492ab9e59ee96aff82f34b6056d657
parentebfb795232803c4776ad24bb84447d64804084c0 (diff)
downloadguix-645aeaf52dfae66506e382f632042bc7fa4643a2.tar.gz
gnu: python-pytensor: Update to 2.14.2.
* gnu/packages/python-science.scm (python-pytensor): Update to 2.14.2.
[native-inputs]: Add python-pytest-mock.
-rw-r--r--gnu/packages/python-science.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 86ba4209fd..4a010b4127 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -785,7 +785,7 @@ functions and around einops with an API and features adapted to xarray.")
 (define-public python-pytensor
   (package
     (name "python-pytensor")
-    (version "2.12.3")
+    (version "2.14.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -794,7 +794,7 @@ functions and around einops with an API and features adapted to xarray.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1445fwbmzkdbndkq9hxiagdkfclgrnmpfzad40zqn6m5ry8192x8"))))
+                "1428l1v7yrnls8875xjx1svn48cmz0q83sv7sg0xdqghkfnyi7xx"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -840,7 +840,10 @@ parentdir_prefix = pytensor-
                         "--ignore" "tests/tensor/"
                         "--ignore" "tests/sandbox/"
                         "--ignore" "tests/sparse/sandbox/")))))))
-    (native-inputs (list python-cython python-pytest python-versioneer))
+    (native-inputs (list python-cython
+                         python-pytest
+                         python-pytest-mock
+                         python-versioneer))
     (propagated-inputs (list python-cons
                              python-etuples
                              python-filelock