summary refs log tree commit diff
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2021-01-18 18:17:50 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-30 15:36:57 +0100
commit6545cef5d748e3657144c125037c2bf9af75153f (patch)
treeda6efe5de304386e1e3ffeb4cf56a20084aa015b
parenteccd448c020d7c34657f644d37cc674bf05eca0e (diff)
downloadguix-6545cef5d748e3657144c125037c2bf9af75153f.tar.gz
gnu: Add julia-datastructures.
* gnu/packages/julia-xyz.scm (julia-datastructures): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index ab5bba1bda..bd7802b814 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -44,6 +44,30 @@ provides a macro that lets you use the latest syntax in a backwards-compatible
 way.")
     (license license:expat)))
 
+(define-public julia-datastructures
+  (package
+    (name "julia-datastructures")
+    (version "0.18.9")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaCollections/DataStructures.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0hdqp8ipsqdw5bqqkdvz4j6n67x80sj5azr9vzyxwjfsgkfbnk2l"))))
+    (propagated-inputs
+     `(("julia-compat" ,julia-compat)
+       ("julia-orderedcollections" ,julia-orderedcollections)))
+    (build-system julia-build-system)
+    (home-page "https://github.com/JuliaCollections/DataStructures.jl")
+    (synopsis "Julia module providing different data structures")
+    (description "This package implements a variety of data structures,
+including, @code{CircularBuffer}, @code{Queue}, @code{Stack},
+@code{Accumulators}, @code{LinkedLists}, @code{SortedDicts} and many others.")
+    (license license:expat)))
+
 (define-public julia-orderedcollections
   (package
     (name "julia-orderedcollections")