summary refs log tree commit diff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-01-11 00:28:25 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-11 00:36:13 +1000
commit6573ac82ad83cacd264ae20f9266d21cb5852f12 (patch)
treeb53c9fcb56a99e03ac7748d531d840a7ffa5b55f
parent695bea9803b6ab12ba9fe8a55d663745c97cf55b (diff)
downloadguix-6573ac82ad83cacd264ae20f9266d21cb5852f12.tar.gz
gnu: bedtools: Use modify-phases.
* gnu/packages/bioinformatics.scm (bedtools)[arguments]: Use modify-phases.
-rw-r--r--gnu/packages/bioinformatics.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c5983274c3..df0e23da89 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -224,25 +224,25 @@ computational cluster.")
     (arguments
      '(#:test-target "test"
        #:phases
-       (alist-cons-after
-        'unpack 'patch-makefile-SHELL-definition
-        (lambda _
-          ;; patch-makefile-SHELL cannot be used here as it does not
-          ;; yet patch definitions with `:='.  Since changes to
-          ;; patch-makefile-SHELL result in a full rebuild, features
-          ;; of patch-makefile-SHELL are reimplemented here.
-          (substitute* "Makefile"
-            (("^SHELL := .*$") (string-append "SHELL := " (which "bash") " -e \n"))))
-        (alist-delete
-         'configure
-         (alist-replace
-          'install
-          (lambda* (#:key outputs #:allow-other-keys)
-            (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
-              (for-each (lambda (file)
-                          (install-file file bin))
-                        (find-files "bin" ".*"))))
-          %standard-phases)))))
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-makefile-SHELL-definition
+           (lambda _
+             ;; patch-makefile-SHELL cannot be used here as it does not
+             ;; yet patch definitions with `:='.  Since changes to
+             ;; patch-makefile-SHELL result in a full rebuild, features
+             ;; of patch-makefile-SHELL are reimplemented here.
+             (substitute* "Makefile"
+               (("^SHELL := .*$")
+                (string-append "SHELL := " (which "bash") " -e \n")))
+             #t))
+         (delete 'configure)
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
+               (for-each (lambda (file)
+                           (install-file file bin))
+                         (find-files "bin" ".*")))
+             #t)))))
     (home-page "https://github.com/arq5x/bedtools2")
     (synopsis "Tools for genome analysis and arithmetic")
     (description