summary refs log tree commit diff
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2020-02-15 21:04:07 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-23 00:44:55 +0100
commit659bc4362d97c1e668ec05ec7f4a0fb09bcd440a (patch)
treeea971b2cd599cc4073ef3917e24c4ffd609945af
parent999f1f0bb42be6a43455332fc3642dc568af8d56 (diff)
downloadguix-659bc4362d97c1e668ec05ec7f4a0fb09bcd440a.tar.gz
gnu: Add lmdbxx.
* gnu/packages/databases.scm (lmdbxx): New variable.
-rw-r--r--gnu/packages/databases.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0f023e0c46..c21ca5a490 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -39,6 +39,7 @@
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2106,6 +2107,35 @@ multiple cores.  The size of each database is limited only by the size of the
 virtual address space — not physical RAM.")
     (license license:openldap2.8)))
 
+(define-public lmdbxx
+  (package
+    (name "lmdbxx")
+    (version "0.9.14.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/drycpp/lmdbxx.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1jmb9wg2iqag6ps3z71bh72ymbcjrb6clwlkgrqf1sy80qwvlsn6"))))
+    (arguments
+     `(#:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (build-system gnu-build-system)
+    (inputs `(("lmdb" ,lmdb)))
+    (home-page "http://lmdbxx.sourceforge.net")
+    (synopsis "C++11 wrapper for the LMDB embedded B+ tree database library")
+    (description "@code{lmdbxx} is a comprehensive @code{C++} wrapper for the
+@code{LMDB} embedded database library, offering both an error-checked
+procedural interface and an object-oriented resource interface with RAII
+semantics.")
+    (license license:unlicense)))
+
 (define-public libpqxx
   (package
     (name "libpqxx")