summary refs log tree commit diff
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2021-11-02 06:37:17 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-12-01 17:03:34 +0100
commit660062a65b81cb4bcc95ae87578df5b6bfebbf58 (patch)
tree3b30985fd809c0c0646c5954a118a58da003386d
parentf3861469b6b450f6b8bd18a565789ed28b25a859 (diff)
downloadguix-660062a65b81cb4bcc95ae87578df5b6bfebbf58.tar.gz
gnu: Add go-github-com-mattn-go-runewidth.
* gnu/packages/golang.scm (go-github-com-mattn-go-runewidth): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 236c9f1c2a..625194c563 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8883,3 +8883,27 @@ averages.")
      "This package implements Unicode Text Segmentation according to
 @url{https://unicode.org/reports/tr29/, Unicode Standard Annex #29}.")
     (license license:expat)))
+
+(define-public go-github-com-mattn-go-runewidth
+  (package
+    (name "go-github-com-mattn-go-runewidth")
+    (version "0.0.13")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mattn/go-runewidth")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1yir0f3wc5z5hnkwhvx5qb6nmpfb05zp2gvfjvna63s8kmla1rrn"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/mattn/go-runewidth"))
+    (propagated-inputs
+     `(("go-github-com-rivo-uniseg" ,go-github-com-rivo-uniseg)))
+    (home-page "https://github.com/mattn/go-runewidth")
+    (synopsis "Rune width implementation for Go")
+    (description
+     "This package provides functions to get the fixed width of a character or
+string.")
+    (license license:expat)))