summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-06-22 17:24:10 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-22 17:55:05 +0200
commit6623d1cd7f3298f2e5c224299d11a77f7ae18bf5 (patch)
treed9ebf2da1c5ac337ef0b024b367442c5a038f5b8
parentb9a95420abdf4ae7fe9a347031278a44ad6a1cce (diff)
downloadguix-6623d1cd7f3298f2e5c224299d11a77f7ae18bf5.tar.gz
gnu: python-numpy, python-scipy: Remove dependency on lapack.
The dependency on lapack was unused; the LAPACK interface of OpenBLAS is
used instead.  The dependency on lapack was added in
cba256f8faaa18457fc9b77e8b401f17b89bdd75 (numpy) and
719b01c1575b8599b0dca9f245a9d759032f3168 (scipy).

* gnu/packages/python-science.scm (python-scipy)[inputs]: Remove
LAPACK.
* gnu/packages/python-xyz.scm (python-numpy)[inputs]: Likewise.
-rw-r--r--gnu/packages/python-science.scm3
-rw-r--r--gnu/packages/python-xyz.scm5
2 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 10fb2403e6..d2c4caac3a 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -73,8 +73,7 @@
        ("python-matplotlib" ,python-matplotlib)
        ("python-pyparsing" ,python-pyparsing)))
     (inputs
-     `(("lapack" ,lapack)
-       ("openblas" ,openblas)
+     `(("openblas" ,openblas)
        ("pybind11" ,pybind11)))
     (native-inputs
      `(("python-cython" ,python-cython)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 744648b9f3..7ff7c1e4cc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014, 2015, 2016, 2019 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014, 2017, 2021 Eric Bavier <bavier@posteo.net>
@@ -4950,8 +4950,7 @@ between language specification and implementation aspects.")
          "1ak9dmjja0q90a7fsxli51ypcwssh8c4pb6f8wkrsnf2xgdk6dy9"))))
     (build-system python-build-system)
     (inputs
-     `(("openblas" ,openblas)
-       ("lapack" ,lapack)))
+     `(("openblas" ,openblas)))
     (native-inputs
      `(("python-cython" ,python-cython)
        ("python-pytest" ,python-pytest)