summary refs log tree commit diff
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-05-09 22:14:36 -0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-05-09 22:14:36 -0400
commit663c06e8cd7d44443b0495b13f2bb08e2cfab889 (patch)
tree8f3dbb2eb2c923961b22839f927a1b9accb32177
parentcb1248d2082ff8292e2516f124feea4427cf150a (diff)
downloadguix-663c06e8cd7d44443b0495b13f2bb08e2cfab889.tar.gz
Disable building in chroot for Nix's corepkgs
The dependencies of the corepkgs are not necessarily in the chroot (or
in the Nix store), so don't build them in a chroot.
-rw-r--r--corepkgs/buildenv.nix3
-rw-r--r--corepkgs/nar.nix3
-rw-r--r--corepkgs/unpack-channel.nix4
3 files changed, 10 insertions, 0 deletions
diff --git a/corepkgs/buildenv.nix b/corepkgs/buildenv.nix
index 641231dd9e..50c9923af7 100644
--- a/corepkgs/buildenv.nix
+++ b/corepkgs/buildenv.nix
@@ -18,4 +18,7 @@ derivation {
   # Building user environments remotely just causes huge amounts of
   # network traffic, so don't do that.
   preferLocalBuild = true;
+
+  # Don't build in a chroot because Nix's dependencies may not be there.
+  __noChroot = true;
 }
diff --git a/corepkgs/nar.nix b/corepkgs/nar.nix
index 5be8be10c1..4747dc31de 100644
--- a/corepkgs/nar.nix
+++ b/corepkgs/nar.nix
@@ -28,4 +28,7 @@ derivation {
   builder = shell;
   args = [ "-e" builder ];
   inherit storePath hashAlgo;
+
+  # Don't build in a chroot because Nix's dependencies may not be there.
+  __noChroot = true;
 }
diff --git a/corepkgs/unpack-channel.nix b/corepkgs/unpack-channel.nix
index 0fc2b2f456..245430ab0f 100644
--- a/corepkgs/unpack-channel.nix
+++ b/corepkgs/unpack-channel.nix
@@ -8,6 +8,10 @@ derivation {
   args = [ "-e" ./unpack-channel.sh ];
   inherit name channelName src bzip2 tar tr;
   PATH = "${nixBinDir}:${coreutils}";
+  
   # No point in doing this remotely.
   preferLocalBuild = true;
+
+  # Don't build in a chroot because Nix's dependencies may not be there.
+  __noChroot = true;
 }