summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-09-10 16:38:43 +0200
committerRoel Janssen <roel@gnu.org>2020-09-10 16:38:43 +0200
commit66be746dc0c0f4ba3d748ed8d0983b2f9afdace8 (patch)
tree9ca34a49357a0cd5bc4a1ac65fe258a3d976631f
parenta5c151de0a7a75bf3803c51856f8c8c928361155 (diff)
downloadguix-66be746dc0c0f4ba3d748ed8d0983b2f9afdace8.tar.gz
gnu: Move r-bisquerna.
* gnu/packages/bioinformatics.scm (r-bisquerna): Move to ...
* gnu/packages/cran.scm: ... here.
-rw-r--r--gnu/packages/bioinformatics.scm25
-rw-r--r--gnu/packages/cran.scm25
2 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 96cc71babc..cab3df222c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7897,31 +7897,6 @@ manipulating genomic intervals and variables defined along a genome.")
 on Bioconductor or which replace R functions.")
     (license license:artistic2.0)))
 
-(define-public r-bisquerna
-  (package
-   (name "r-bisquerna")
-   (version "1.0.4")
-   (source (origin
-            (method url-fetch)
-            (uri (cran-uri "BisqueRNA" version))
-            (sha256
-             (base32
-              "01g34n87ml7n3pck77497ddgbv3rr5p4153ac8ninpgjijlm3jw2"))))
-   (properties `((upstream-name . "BisqueRNA")))
-   (build-system r-build-system)
-   (propagated-inputs
-    `(("r-biobase" ,r-biobase)
-      ("r-limsolve" ,r-limsolve)))
-   (home-page "https://www.biorxiv.org/content/10.1101/669911v1")
-   (synopsis "Decomposition of Bulk Expression with Single-Cell Sequencing")
-   (description "This package provides tools to accurately estimate cell type
-abundances from heterogeneous bulk expression.  A reference-based method
-utilizes single-cell information to generate a signature matrix and
-transformation of bulk expression for accurate regression based estimates.
-A marker-based method utilizes known cell-specific marker genes to measure
-relative abundances across samples.")
-   (license license:gpl3)))
-
 (define-public r-annotationdbi
   (package
     (name "r-annotationdbi")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8f7e379e42..27fae416f8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2183,6 +2183,31 @@ where the bound function accepts additional arguments.")
 bindings that call a C++ function.")
     (license license:expat)))
 
+(define-public r-bisquerna
+  (package
+   (name "r-bisquerna")
+   (version "1.0.4")
+   (source (origin
+            (method url-fetch)
+            (uri (cran-uri "BisqueRNA" version))
+            (sha256
+             (base32
+              "01g34n87ml7n3pck77497ddgbv3rr5p4153ac8ninpgjijlm3jw2"))))
+   (properties `((upstream-name . "BisqueRNA")))
+   (build-system r-build-system)
+   (propagated-inputs
+    `(("r-biobase" ,r-biobase)
+      ("r-limsolve" ,r-limsolve)))
+   (home-page "https://www.biorxiv.org/content/10.1101/669911v1")
+   (synopsis "Decomposition of bulk expression with single-cell sequencing")
+   (description "This package provides tools to accurately estimate cell type
+abundances from heterogeneous bulk expression.  A reference-based method
+utilizes single-cell information to generate a signature matrix and
+transformation of bulk expression for accurate regression based estimates.
+A marker-based method utilizes known cell-specific marker genes to measure
+relative abundances across samples.")
+   (license license:gpl3)))
+
 (define-public r-auc
   (package
     (name "r-auc")