summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-08-16 11:19:56 +0200
committerLudovic Courtès <ludo@gnu.org>2019-08-16 23:00:27 +0200
commit66d146639d0dfd2efaed4a429dbb845172dc4f24 (patch)
tree8e900ba2902cd7c5693cf7130bdb449e5b13b05f
parent3b165f2a401a6f890f5f93371bdf137daf09c493 (diff)
downloadguix-66d146639d0dfd2efaed4a429dbb845172dc4f24.tar.gz
gnu: txr: Update to 223.
* gnu/packages/lisp.scm (txr): Update to 223.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/lisp.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d2bed231bd..a42369ba06 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5319,7 +5319,7 @@ port within a range.")
 (define-public txr
   (package
     (name "txr")
-    (version "216")
+    (version "223")
     (source
      (origin
        (method url-fetch)
@@ -5329,7 +5329,7 @@ port within a range.")
        (patches (search-patches "txr-shell.patch"))
        (sha256
         (base32
-         "07cxdpc9zsqd0c2668g00dqjpd6zc4mfdn74aarr6d2hpzdhh937"))))
+         "0109q8idqggba3kx58dpm5ccfpdrki68npkcxm18p5ga24611fcv"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("cc=gcc")
@@ -5343,7 +5343,7 @@ port within a range.")
                       #t))
                   (replace 'check
                     (lambda _
-                      (zero? (system* "make" "tests")))))))
+                      (invoke "make" "tests"))))))
     (native-inputs
      `(("bison" ,bison)
        ("flex" ,flex)))