summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-24 23:03:07 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-24 23:56:43 +0100
commit6713589d6beca4bdc3b7acbeb4e8975ef3ceb7cf (patch)
tree6658bee688ca22e1d9e35f82142e7db23dde36eb
parent01e5d63c87b6b110f0632597e89a6a7476fc7d1c (diff)
downloadguix-6713589d6beca4bdc3b7acbeb4e8975ef3ceb7cf.tar.gz
gnu: guile-ics: Add "guile3.0-ics" variant.
* gnu/packages/guile-xyz.scm (guile-ics)[source]: Add 'modules' and 'snippet'.
(guile3.0-ics): New variable.
-rw-r--r--gnu/packages/guile-xyz.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 029054b90e..835539aec9 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1493,7 +1493,15 @@ provides tight coupling to Guix.")
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "0qjjvadr7gibdq9jvwkmlkb4afsw9n2shfj9phpiadinxk3p4m2g"))))
+                "0qjjvadr7gibdq9jvwkmlkb4afsw9n2shfj9phpiadinxk3p4m2g"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; Allow builds with Guile 3.0.
+                  (substitute* "configure.ac"
+                    (("^GUILE_PKG.*")
+                     "GUILE_PKG([3.0 2.2 2.0])\n"))
+                  #t))))
     (build-system gnu-build-system)
     (native-inputs
      `(("autoconf" ,autoconf-wrapper)
@@ -1513,6 +1521,14 @@ pure Scheme.  The library can be used to read and write iCalendar data.
 The library is shipped with documentation in Info format and usage examples.")
     (license license:gpl3+)))
 
+(define-public guile3.0-ics
+  (package
+    (inherit guile-ics)
+    (name "guile3.0-ics")
+    (inputs `(("guile" ,guile-3.0)
+              ,@(alist-delete "guile" (package-inputs guile-ics))))
+    (propagated-inputs `(("guile-lib" ,guile3.0-lib)))))
+
 (define-public guile-wisp
   (package
     (name "guile-wisp")