summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-12 21:38:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-14 14:15:33 +0100
commit6822730c8de2ff33902ba7cf0d4af80226b62775 (patch)
treee30978d2184a6674b0d69058b038bc172be344ee
parentc20e80b1020295fc84757b0be4ddef3c59784c17 (diff)
downloadguix-6822730c8de2ff33902ba7cf0d4af80226b62775.tar.gz
gnu: pcb: Use gexp.
* gnu/packages/engineering.scm (pcb)[arguments]: Use gexp and drop trailing #T
from build phases.
-rw-r--r--gnu/packages/engineering.scm56
1 files changed, 26 insertions, 30 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 4626800dc9..25fe1398dc 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -433,37 +433,33 @@ features.")))
                 "1a7rilp75faidny0r4fdwdxkflyrqp6svxv9lbg7h868293962iz"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'use-wish8.6
-           (lambda _
-             (substitute* "configure"
-               (("wish85") "wish8.6"))
-             #t))
-         ;; It checks for "xhost", which we don't have.  This shouldn't
-         ;; matter, because the test is supposed to be skipped, but it causes
-         ;; "run_tests.sh" (and thus the "check" phase) to fail.
-         (add-after 'unpack 'fix-check-for-display
-           (lambda _
-             (substitute* "tests/run_tests.sh"
-               (("have_display=no") "have_display=yes"))
-             #t))
-         (add-after 'install 'wrap
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             ;; FIXME: Mesa tries to dlopen libudev.so.0 and fails.  Pending a
-             ;; fix of the mesa package we wrap the pcb executable such that
-             ;; Mesa can find libudev.so.0 through LD_LIBRARY_PATH.
-             (let* ((out (assoc-ref outputs "out"))
-                    (path (dirname
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'use-wish8.6
+            (lambda _
+              (substitute* "configure"
+                (("wish85") "wish8.6"))))
+          ;; It checks for "xhost", which we don't have.  This shouldn't
+          ;; matter, because the test is supposed to be skipped, but it causes
+          ;; "run_tests.sh" (and thus the "check" phase) to fail.
+          (add-after 'unpack 'fix-check-for-display
+            (lambda _
+              (substitute* "tests/run_tests.sh"
+                (("have_display=no") "have_display=yes"))))
+          (add-after 'install 'wrap
+            (lambda* (#:key inputs #:allow-other-keys)
+              ;; FIXME: Mesa tries to dlopen libudev.so.0 and fails.  Pending a
+              ;; fix of the mesa package we wrap the pcb executable such that
+              ;; Mesa can find libudev.so.0 through LD_LIBRARY_PATH.
+              (let ((path (dirname
                            (search-input-file inputs "/lib/libudev.so"))))
-               (wrap-program (string-append out "/bin/pcb")
-                 `("LD_LIBRARY_PATH" ":" prefix (,path))))
-             #t))
-         (add-before 'check 'pre-check
-           (lambda _
-             (system "Xvfb :1 &")
-             (setenv "DISPLAY" ":1")
-             #t)))))
+                (wrap-program (string-append #$output "/bin/pcb")
+                  `("LD_LIBRARY_PATH" ":" prefix (,path))))))
+          (add-before 'check 'pre-check
+            (lambda _
+              (system "Xvfb :1 &")
+              (setenv "DISPLAY" ":1"))))))
     (inputs
      `(("dbus" ,dbus)
        ("mesa" ,mesa)